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Goals

By the end of this class, you’ll:

• Be familiar with basic electionics concepts
• Assemble a kit of sensors into a complete system
• Know how to program the Arduino platform to collect and plot

the sensor data
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UnPacked / Unlondon

Enabling Exploration, Creativity, and
Excellence In Art+Make+Tech

Challenging and embracing ideas related to new technologies and
social platforms through the education, entertainment and
engagement of our membership and the community-at-large.

• 121Studios: Coworking for Creatives
• STEAM Outreach & Education
• ExplodeConf
• Nuit Blanche
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What’s in your kit?
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Kit Contents

Arduino Uno R3

Solderless Breadboard

Connecting wires

Sensors

• Temperature / Humidity
• Light Sensor
• CO2 Gas Sensor
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What is Arduino?

It’s a kit (on a board) with the bare minimum components to easily
use the µC hardware. They do the basic, boring design needed for

any board, so users only need to add the neat stuff.
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Arduino Software

The Arduino folks also adapted an Integrated Development
Environment (IDE) to their boards. This IDE allows us to easily
write programs for their boards and then transfer the programs to
the µC.

Get the Arduino IDE:
https://www.arduino.cc/en/Main/Software

Get the libraries and sample code for this workshop:
https://monadnock.ca/lts-workshop-Nov2017.zip
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Circuit Basics
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Current

Current is the flow of charge through a circuit. Measured in
Amperes (A).
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Resistance / Impedance

Circuits have a resistance to current flow that depends on the parts
in the circuit.

Measured in Ohms (Ω)
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Voltage

Voltage is a potential (akin to a pressure) pushing the current
through a circuit. Current is said to flow from higher (+) voltage to
lower (-) voltage.

Measured in Volts (V)
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Ohm’s Law; Light

Voltage, Current and Resistance are related to each other.

• As voltage increases, current increases
• As voltage decreases, current decreases
• As resistance increases, current decreases
• As resistance decreases, current increases
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V, Ω, A: The Water Analogy

If charge were water, then:

• resistance = obstacles blocking flow
• current = flow rate
• voltage = change in height or pressure.
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Diode

• One way value for current1

• LED ≡ Light Emitting Diode
• Band marks (-)2

• Longer leg marks (+)

1
https://learn.sparkfun.com/tutorials/diodes

2
https://learn.sparkfun.com/tutorials/polarity/diode-and-led-polarity
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Diode Problems

• Diodes don’t limit current
• Diodes aren’t perfect (some current turned to heat)
• Too much current → Too much heat →

What’s that smell?
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Resistor

• Resists/limits the flow of
current

• Needed for LEDs: ≈ 1000Ω
• Button Pull-up/down:
≥ 10 kΩ

• Color coded, Google it
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Buttons

• Buttons connect or disconnect two wires/parts
• Momentary Switch: Normally Closed (NC), Normally Open

(NO)
• Toggle Switch
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Circuits

A circuit is a completed loop from HIGH potential (voltage) to
LOW, which causes current to flow through some other components
along the way.
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Transducers

Often these other components are transducers, which convert
electrical energy into another sort of energy:

Speaker Electrical → Sound
Microphone Sound → Electrical
LED Electrical → Light
LED Light → Electrical
Piezoelectric Electrical → Motion
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Power

The power supply provides the energy to drive the system.

Can be a:

• Voltage Regulator (converts one potential to another)
• Batteries
• Solar Panel

In our circuits, your computer is converting it’s power source to 5V
and delivering power to our circuit via USB.
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µController

Microcontroller (µC) is a processor, memory and a few peripherals
on a standalone chip.

Processor is a group of transistors that understands a dozen or
so commands (ADD, SUB, JUMP..)

Memory a circuit that can hold values.
Peripherals Vary chip to chip, but often include timers,

communications and ADC, DAC.

Seems complicated, but really simple. They read a command from
the start of memory, then execute the command. At the end of the
command, read the next command from the next memory cell and
repeat1

1some commands change the address of the next fetched command
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Digital Signals

• Vcc: The power supply of the circuit elements
• GND: The reference voltage (usually 0 V)
• Connecting a part to Vcc = Logical 1 or High
• Connecting to GND = Logical 0 or Low
• Connecting various pins to Vcc or Ground is all the µC can do

to talk to the world 2

2w/o fancy peripherals or dirty tricks
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µController INPUT and OUTPUT

Most of the pins on the Arduino can be set for INPUT or OUTPUT
mode.

• INPUT mode pins listen for a signal (High or Low) from
another device

• OUTPUT mode pins drive the pin High or Low
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Floating Pins

What’s happens if an INPUT mode pin tries to read the value of a
pin that is connected to nothing? Is that a 1 or 0?

No one knows!
It’s dependant of transient charges, static, nearby electric fields, the
phase of the moon, . . .Whenever you want to check a digital signal,

make sure that something is driving it (ensuring Vcc or GND).
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µC + Digital Signals as Switches

If one end of an LED is connected to ground, and the other end is
connected to an OUTPUT pin on a µController, then:

• If the µC sets the pin High (Vcc, 5 V) then current will flow
from the pin through the LED and turn it on.

• If µC sets the pin Low (GND, 0V) then the current will not
flow and the LED is off.
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Let’s start programming
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Configure Arduino

• Board: Arduino/Genuino UNO
• Port: . . .
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Fetch the Class Code

Download and extract:
https://monadnock.ca/static/lts-workshop-Nov2017.zip

• File→Preferences
• Browse for sketchbook
• Point it at the sketchbook subfolder of the extracted

download
• You should now see a list of projects in the File→Sketchbook

menu.
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Setup the Sensor Libraries (Sketchbook)

For the Sketchbook Location browse to the extracted
lts-workshop-Nov2017/sketchbook directory.
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The Code Environment
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Your first Program

#define LED 13

/* the setup function runs once on reset / power */
void setup() {

pinMode(LED, OUTPUT);
}

/* loop() repeats until reset or power off */
void loop() {

digitalWrite(LED, HIGH); // turn on LED
delay(1000); // wait for a second
digitalWrite(LED, LOW); // turn the off LED
delay(1000);

}
31



Lets Add Some Parts
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Breadboard

• Connectors gently pinch component leads, wires.
• Have internal connections
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Power Up the Rails

We use the long rows to distribute power. The Arduino outputs 5V
on the pin marked 5V, the reference (GND) is marked GND.
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DHT11: Temperature and Humidity Sensor
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DHT11: Zoom

Connect left pin to Vcc rail (+) and right pin to GND (−) rail.
Second from left connects to Arduino pin #2 and a resistor to Vcc
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Pullup / Pulldown Resistors

The DHT11 uses an Open Collector output that switches between
Not Connected and Connected to Ground. When it’s not connected,
the pin is left floating. How do we make a floating pin look like a
High signal?

Solution:

Connect the pin to Vcc so that it reads High; use a resistor to
prevent short circuit (limit current).
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DHT11: Run example code

We can test the sensor by running sample code from the library.

Open the sample: File→Examples→DHT Sensor
Library→DHTtester

Once the sample is loaded click the upload button (looks like right
arrow)
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Arduino Serial Monitor

Once the sample code is uploaded, you can open the Serial Monitor
to view the output. It can be found under:

Tools→Serial Monitor
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DHTtester Output
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TSL2561: Ambient Light Sensor
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TSL2561: Zoom

Connect Vin to (+) rail, GND to (−) rail, SDA to Arduino pin A4
and SCL to A5
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TSL2561: Run example code

We can test the sensor by running sample code from the library.

Open the sample: File→Examples→Adafruit TSL2561→sensorapi

Once the sample is loaded click the upload button (looks like right
arrow)
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TSL2561 Sample Output
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CCS811: Gas Sensor
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CCS811: Zoom

Vin to (+) rail, GND and WAKE to (−) rail, SDA to TSL2561
SDA, SCL to TSL2561 SCL
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CCS811: Run example code

We can test the sensor by running sample code from the library.

Open the sample: File→Examples→Adafruit CCS811
Library→CCS811_test

Once the sample is loaded click the upload button (looks like right
arrow)

47



CCS811 Sample Output
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Programming
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Part 1; Includes

#include <Wire.h>
#include <Adafruit_Sensor.h>
#include <Adafruit_TSL2561_U.h>
#include "Adafruit_CCS811.h"
#include "DHT.h"
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Part 2; Definitions

#define DHTPIN 2
#define DHTTYPE DHT11
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Part 3; Objects

Adafruit_CCS811 ccs;
DHT dht(DHTPIN, DHTTYPE);
Adafruit_TSL2561_Unified tsl =

Adafruit_TSL2561_Unified(TSL2561_ADDR_FLOAT, 12345);
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Programming Note: Variables

Declare a variable:

int button_state = HIGH;

<type> <name> [= <initial value>]; (value optional)

It’s a name, like a preprocessor #define, but the value can change
at runtime
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Part 4; Setup

void setup() {
Serial.begin(9600);
Serial.println("Let's Talk Science!");

dht.begin();
ccs.begin();
tsl.begin();

while(!ccs.available());
float temp = ccs.calculateTemperature();
ccs.setTempOffset(temp - 25.0);

tsl.enableAutoRange(true);
tsl.setIntegrationTime(TSL2561_INTEGRATIONTIME_13MS);
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Part 4; Main Loop

loop () {
delay(500);
...

}
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Part 4a; Temperature / Humity Sensor Read

loop () {
...
float humidity = dht.readHumidity();
float temp = dht.readTemperature();

Serial.print(humidity);
Serial.print(" ");
Serial.print(temp);
Serial.print(" ");
...

}
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Part 4b; Gas Sensor Read

loop () {
...
ccs.readData();
int co2 = ccs.geteCO2();
int tvoc = ccs.getTVOC();

Serial.print(co2/100);
Serial.print(" ");
Serial.print(tvoc/10);
Serial.print(" ");

}
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Part 4c; Light Sensor Read

loop () {
...
sensors_event_t event;
tsl.getEvent(&event);

Serial.print(event.light/10);
...

}
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Part 4d; Ending the output

loop () {
...
Serial.println("");

}
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Complete Sensor Output
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Arduino Serial Plotter

Why such a terse, boring output format?

Arduino has a feature where it will plot data in this specific format.
You can see the plotted output by closing the Arduino Serial
Monitor and Opening Arduino Serial Plotter (Tools→Serial Plotter)
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Arduino Serial Plotter Output
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Undiscussed Issues
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Obtaining the kit

• Educators would need to order several different parts (SKUs).
• Vendors keep very little stock (~4 dozen).
• Educators may need to “google around” to find parts, most

likely from abroad (US or China)
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Installing the Software

• School machines may prevent software installation
• School machines may not be conventional computers (iPads,

Chromebooks)
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Troubleshooting the Build

• Breadboards aren’t rugged.
• Sockets wear out quickly
• Parts may need to be wiggled
• Some parts may be DoA
• Most troubleshooting requires a Multimeter (and training on

how to use it)
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Extra Credit
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Ohm’s Law

Ohm’s Law relates current to potential and resistance.

V = IR

I = V
R

R = V
I

• V = Potential in Volts (V)
• I = Current in Amperes (A)
• R = Resistance in Ohms (Ω)
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Ohm’s Law: Example

The datasheet for an LED says that the maximum continuous
current is 15mA. Your circuit operates at 5V1. How big should
your resistor be?

Ω = 5V
0.015A = 333.3Ω

How much current for our cheet sheet value?

A = 5V
1 kΩ = 5mA

1Actually, this calculation is inaccurate. LEDs will have a *forward voltage drop* of between 1.8 V and 3.3 V this
should be subtracted from V above... but it’s not critical.
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Current Limits, Arduino

• No single pin should source more that 20mA (40mA is
absolute max)

• Pins are ganged together in groups of 8, no group should
source more than 150mA total

• The whole board cannot source more than 200mA total

Practically speaking, this means that the Arduino cannot drive
speakers, most motors, or anything normally mains powered.
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So. . . no Arduino smart blender?

You can control almost anything with an arduino, you just can’t
power it with the Arduino. There are various devices that let you
switch highier powered devices:

• Transistors
• Relays
• Solid State Relays
• Triac
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HIGHs and LOWs

Many different logic levels are in common use: 1.2V, 1.8V, 2.5V,
3.3V, and 5V. The voltage cited is the nominal Vcc of the system.

A HIGH signal is generally any voltage ≥ 2
3Vcc .

A LOW signal is generally any voltage ≤ 1
3Vcc .
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HIGHs and LOWs, pt. 2

In your travels, you’re likely to see both 5V and 3.3V sensors and
peripherals.

Since 3.3V ≥ 2
3Vcc your Arduino will accept input from a 3.3V

peripheral without issue.

If you drive an output to 5V while it’s connected to a 3.3V
peripheral with an Arduino it will blow up your peripheral.3

3In the datasheet for the sensor, it’ll have a section called Absolute Maximums.
Generally 3.3 V parts won’t accept more that ≈ 3.6 V, but some will.
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HIGHs and LOWs, pt. 3

Solutions:

• Level Shifter: A dedicated chip that translates between
voltages. Available as uni or bidirectional.

• Buy a 3.3V Arduino Compatible. Arduinos are available that
operate at the lower voltage.
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